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Purpose 
The purpose of this document is to (a) provide divers with the basic knowledge and skillset for creating 2-
dimensional, underwater photomosaics- also referred to as orthomosaics, structure from motion (SfM), or 
several similar descriptors- and (b) explain one method for analyzing photomosaics to quantify coral reef 
restoration. It should be noted that while this document will describe several methods for acquiring 
photomosaics, many additional methods and techniques exist across the various underwater science 
communities. Additional sources of information on such techniques are listed on the final page of this 
manual. As photomosaics and their uses in underwater science are a continuously evolving field, the reader 
should carefully consider their needs and capacities, and choose techniques to suit their work. For readers 
interested in 3-dimensional modeling of reef restoration efforts and some of the measurements used 
therein, CRFTM has released an extensive 3-dimensional monitoring manual, available at 
www.coralrestoration.org/white-papers.  

Background 

A photomosaic is an image comprised of multiple individual and overlapping images that are digitally 
stitched together into a single image file. Thus, a photomosaic can depict a scene larger than can be 
encompassed by any individual photograph, without significant sacrifices in image resolution or vantage 
point. 
 
In various disciplines of marine science, benthic photomosaics are a critical scientific tool in mapping 
submerged objects of interest, such as shipwrecks or topographic structure. Specific to reef restoration and 
conservation, photomosaics are invaluable in mapping large reef areas, assessing benthic coverage of 
different biota, and monitoring corals outplanted as a part of reef restoration efforts. Recent 
developments in underwater camera technology, as well as software and computing power, have allowed 
for the rapid creation of incredibly high-resolution photomosaics, without extensive financial investment or 
intensive training. Furthermore, these advances have granted the average diver the ability to produce 
quality photomosaics easily, provided the diver has been in trained in the appropriate techniques for 
image acquisition and digital photomosaic stitching.  
  

http://www.coralrestoration.org/
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Part I – Introduction to In-Water Image Acquisition 

Theory 

In order to consistently produce quality photomosaics, a method for the in-water acquisition of 
”stitchable” individual images must be learned. Parts I and II of this document will detail a 
“Beginner/Easy” method for acquiring these images and an “Advanced/Hard” method for acquiring 
these images. Both methods are commonly used by Coral Restoration FoundationTM (CRFTM) in day-to-
day operations and differ only in the experience level of the dive team utilizing them. Part III of this 
document outlines several other methods for acquiring in-water imagery and while these methods are 
used by CRF, they require additional equipment or serve alternative purposes and therefore warrant 
separate explanation. 
 
Regardless of the method(s) selected for use, the primary goal of the in-water photomosaic procedures is 
simple: obtain photos that can be stitched together to create the photomosaic. In order for a set of photos 
to be stitched together, they must meet several criteria. First, the photos must have sufficient overlap- at 
least 60% in each dimension. This overlap is ensured by placing the cameras in the appropriate locations 
on the camera rig, swimming with the cameras at a consistent pace, and setting the appropriate time lapse 
interval on the cameras. Second, the photos must be clear (i.e. without motion blur), a problem that can be 
avoided with clean/unscratched filters and housings, an appropriate time lapse interval, and by swimming 
smoothly and constantly. Finally, the photos should be organized and stored in a redundant and 
consistently labeled information architecture immediately after the in-water work is completed to 
streamline the stitching process and avoid confusion or the loss of files. 

CRF’s Required Equipment          

• Minimum (2) GoPro cameras (recommended Hero 5 or later model) with following accessories for 
each: 

o Dive housings 
o Red filters (if necessary for water conditions, though highly recommended) 
o GoPro attachment mounts 
o Batteries and microSD cards (recommended 32 GB or larger) 

• PVC “hammerhead” rig for mounting cameras 

• Scale bars 

• Agisoft Metashape computer software 

• Computer 
o Recommended computer requirements can be found at 

http://www.agisoft.com/downloads/system-requirements/ 
o CRFTM uses a 2017 iMac Pro 27” Retina-Display CPU, with a 2.3 GHz 18-core processor 

and 128 GB of RAM, with a 12 TB RAID hard drive for file storage 
 
Currently, Coral Restoration FoundationTM uses (2) GoPro Hero 9 Black cameras, each with a SuperSuit 
dive housing, and equipped with a red or magenta dive housing filter (dependent on water conditions). 
These cameras are waterproof to 9 meters without the SuperSuit housing but in our experience the 
cameras’ buttons often fail at depths below 3 meters, due to the pressure compressing them into a 
permanent “on” position. Dive filters are not required but CRFTM has had significantly more success utilizing 
the filters, even in shallow and very clear water. In addition to color correcting the blue-green tint of 

http://www.coralrestoration.org/
http://www.agisoft.com/downloads/system-requirements/
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underwater light, the filters also aid in increasing the contrast of the individual GoPro photos, which in turn 
aids in creating an accurate stitch. 
 
In initial phases of CRFTM’s photomosaic program, we experimented with more than two GoPro cameras on 
a camera rig. While increasing the number of cameras used increases the diver’s “field of view” as they 
swim, it was not found to lead to any significant increase in final photomosaic resolution. In fact, using more 
cameras increased the processing time necessary, since more GoPro cameras will result in more individual 
images that need to be stitched. 
 
CRFTM has not found in-camera file storage to be a limiting factor on any photomosaic created to date. 
Each GoPro photo is saved to the internal storage card as a 1 to 3 megabyte JPG file. Thus, a microSD 
card of 32GB would hold over 10,000 images, equivalent to swimming for almost 3 hours on the 1-second 
interval timer mode. 
 
To carry the GoPro cameras, CRFTM created a simple PVC rig, affectionately referred to as a 
“hammerhead” rig. T-connectors are used to attach handles to the main PVC pipe, where SuperSuit 
housings can be attached to mounts. The mounts shown in the below image are GoPro-brand 
handlebar/seat post/pole mounts. 
 

 
The dual-camera “hammerhead” rig, with two GoPro mounts attached (clamps are positioned so that cameras are 

approximately 60cm apart). 

Scale bars can be constructed from nearly any negatively buoyant material (CRFTM has used PVC, dive 
weights, and aluminum scale bars in the past). Our most commonly used scale bars are 50cm aluminum 
scale bars, with coded 12-bit targets etched into either end. These targets allow for rapid detection and 
auto-scaling during the stitching steps of Agisoft Metashape (described later in this manual). Larger, 
“square-end” PVC scale bars (~150cm) can also be beneficial, especially for very large areas or areas of 
poor visibility.  
 
The placement of the scale bars within a photomosaic area is surprisingly important. In addition to 
providing a constant, known distance against which to scale the final photomosaic, scale bars can also 
provide direction to the divers acquiring the in-water imagery. Thus, this document recommends using scale 
bars that are large and/or brightly colored, especially if the area is unfamiliar to the divers or the 
visibility is poor. It should also be noted that small scale bars have a greater tendency to move in areas of 
high surge or territorial fish (i.e. damselfish). Scale bars that move over the course of the image acquisition 
process may not stitch properly in the final photomosaic and will be unreliable in scaling the photomosaic. 
Finally, be sure to place the scale bars level (i.e. horizontal or flat) across the seafloor to avoid warped 
perspectives from the cameras and to preserve the integrity of the orthorectification process, described 
below. This process is most accurate with 4-6 scale bars per mosaic, placed at a variety of depths and 
distributed non-linearly (i.e. not in a straight line) throughout the photomosaic area. 
 

http://www.coralrestoration.org/
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Agisoft Metashape has become the software of choice among the underwater photomosaic community and 
its ability to stitch large numbers of individual images quickly and accurately is impressive. So too, 
however, is the price tag and the computer system required to operate it. CRFTM has acquired a single 
Metashape license for processing its photomosaics on an iMac Pro computer (described above). Additional 
information on the software, as well as the pricing for commercial and educational licenses, can be found 
at the following link: www.agisoft.com. 

Choosing Your Equipment (Cameras and Scale Bars) 

Choosing the correct cameras for your photomosaics will largely come down to the balance of three things: 
cost, resolution, and ease of use/durability. Small action cameras like GoPros have relatively low 
associated costs, are easy to use, and are durable in underwater environments, but lag behind 
DSLR/mirrorless camera systems in photo quality and resolution (though the gap is rapidly closing). By 
contrast, DLSR/mirrorless cameras produce excellent images with sharp contrast and customizable white 
balance, which will in turn create consistent, comparable photomosaic images. However, these cameras are 
typically thousands of dollars, require 3rd party housings (Ikelite, Nauticam, etc.) to be used underwater, 
can be hard to transport and use underwater, and can become quickly ruined in the event of a housing 
leak or crack.  
For the above reasons, CRFTM has opted to use GoPro cameras for its ongoing photomosaic monitoring 
program. We began the program in 2017 with GoPro Hero 5 Black model cameras and have since 
upgraded to Hero 9 Black model cameras. As expected, there are several differences between the 
cameras, two of which are highlighted here. First, the Hero 9 camera contains a much-improved, 20 
megapixel camera sensor. When compared to the Hero 5 camera (12 megapixel sensor), photographs 
from the Hero 9 are clearer, higher contrast, and higher resolution than those of the Hero 5, resulting in 
substantial improvements in the quality and clarity of final photomosaic images. 
 
However, the second difference between the two cameras is the auto-white balance setting. Somewhere 
around the GoPro Hero 7 or Hero 8 models, GoPro significantly altered the way their auto-white balance 
setting reproduces underwater scenes. On the Hero 5, auto-white balance with a red dive filter produced 
consistent, properly balanced underwater photographs (albeit slightly purple-shifted). However, by the 
Hero 9’s release, the underwater white balance had become noticeably yellow-shifted, producing “warm” 
tints on the images. Presumably, this change was made to more accurately depict yellow/brown skin tones 
underwater but the end result is much less accurate and constantly changing auto-white balance setting for 
benthic (coral reef) subjects. 
 
In order to account for this poor auto-white balance performance, but continue using the incredible 
upgrades in image quality afforded by the Hero 9 model, CRFTM usually uses the “Native” white balance 
setting now found on GoPro 9 and 10 models, combined with a magenta color dive filter. We have found 
that the Native setting gives a consistent “faded green” color to underwater images taken throughout the 
acquisition process. Between the magenta filter and some light contrast increases via image editing 
software, a result acceptably close to the old Hero 5 auto-white balance colors can be achieved for clear 
water less than 10 feet in depth. For scenes taken between approximately 12 and 20 feet of depth, 
additional red-shifting must be applied in post-processing to generate a properly white balanced photo.  
 
Note: Although GoPro Hero 10 and 11 cameras each have the capacity to shoot RAW+JPEG files in the Time 
Lapse mode, this feature is limited to intervals of 5 seconds or greater, rendering GoPro RAW file workflows 
impractical for large-scale photomosaic use. 
 
As previously described, any negatively-buoyant object of known length can be used as a scale bar for 
the photomosaic image collection process. However, some items function better as scale bars than others. 
CRFTM currently uses 50cm aluminum bars, with 12-bit coded target etched into the aluminum. These coded 

http://www.coralrestoration.org/
http://www.agisoft.com/
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targets are available from Agisoft via the “Tools->Print Markers” menu in Metashape. During the stitching 
process (described below), Agisoft will recognize these targets automatically, which helps to accelerate the 
scaling and orthorectification processes. Regardless of the material or style of scale bars used, CRFTM 
highly recommends incorporating the Agisoft coded targets in some way. 
 
Our aluminum scale bars are high-contrast and heavy, which ensures that they show up well in both raw 
and final photomosaic imagery and can lay flat without moving when used in areas with strong current or 
surge. However, their weight does make them difficult to carry for long distances underwater; thus, CRFTM 
is currently experimenting with more lightweight scale bars constructed from durable underwater stickers, 
onto which targets are printed and which can then be adhered to thin weights. Targets may also be 
printed onto underwater paper and attached to some form of weight with good results, provided the 
paper does not bend, wrinkle, or tear over time. 
  
 

 
Aluminum scale bars with etched Agisoft coded targets (50cm and 15cm lengths). Numbers correspond to Agisoft’s numbering system 

for 12-bit coded targets. 

 
 

 
Old square-end (above) and stick (below) scale bars, all made from PVC. Agisoft coded targets may be printed separately and 

affixed to the square-end bar with waterproof stickers or glue. 
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Part II – In-Water Procedures: Beginner/Easy Method 

 

 
A diver mosaics an area of reef using the described two GoPro camera setup. 

Pre-Dive Equipment Setup 

Set up the GoPro cameras by checking for charged batteries, cleared microSD cards, and any scratches 
on the camera lenses. Place the cameras in the dive housings and attach the red dive filters. It is 
recommended that the camera’s default mode be set to “Time Lapse” at 1-second intervals to minimize 
the risk of accidentally shooting in video mode or being unable to alter mode settings once in the water. 
 
Attach the dive housings to the GoPro mounts at intervals of about one half meter. For very shallow areas 
where the diver will need to swim at or near the surface, mounting the cameras closer to each other will 
help ensure that there is sufficient overlap between the cameras, since the distance to target (reef) and 
field of view will be reduced. The cameras should typically be oriented to face straight down, though they 

may also be oriented at slight opposite angles (e.g. one camera ~5 forward and one camera ~5 
backward) to aid in accurate stitching of very low rugosity or non-descript areas where more oblique 
views of the substrate can offer an increased number of points for alignment across photos. 
 
If necessary, assemble or prepare the scale bars. 
 
Finally, the specific area of reef to be surveyed should be identified before entering the water, when 
possible. CRFTM uses Google Earth to assess mosaic areas of appropriate size, which are then confirmed as 
suitable for restoration upon arrival and mosaicked. 

http://www.coralrestoration.org/
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Image Capture and Diver Tasks 

This method of image acquisition should be utilized if the diver team is inexperienced in the photomosaic 
process, water conditions (visibility, current, surge, etc.) limit the size of the area that can be efficiently 
mosaicked, or if the area to be mosaicked is larger than ~2,000 m2. This manual recommends acquiring 
imagery for subsections of the full area to be mosaicked, referred to here as “chunks”. The exact size of 
each chunk should be determined by water conditions, comfort and experience of both divers, and the 
presence or absence of significant navigational aids within the reef area. We recommend chunks of 
approximately 250 m2 for new/inexperienced photomosaic divers and approximately 1000 m2 for more 
experienced teams working to photomosaic much larger areas of reef. Diver 1 is the diver with the camera 
rig and Diver 2 is the support/scale bar diver. 
 
The following images explain the steps for photographing adjacent chunks of any size along an area of 
reef: 
 
 

 
 

The above area of reef is to be photographed for a photomosaic. The area has been mentally divided 
into four chunks (blue lines) and Diver 2 has placed the scale bars (black) along the two borders of Chunk 

1 and recorded the depths of the scale bars with their dive computer. 
 

http://www.coralrestoration.org/
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Diver 1 follows the pattern of the yellow arrows, with the cameras in Time Lapse Mode. The first pass 
should travel directly over the first scale bar and the second pass should put that scale bar in view of at 

least one camera. This will ensure sufficient overlap across passes. 
 

 
 

Diver 1 continues making passes until they pass over the second scale bar. This marks the completion of 
Chunk 1, and the cameras should be stopped/paused. Diver 2 now moves the first scale bar to the far side 

of Chunk 2, as shown above, and records the scale bar’s depth. Chunk 2 is now prepped for 
photographing. 

 

http://www.coralrestoration.org/
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Diver 1 proceeds as before, with the first pass of Chunk 2 traveling directly over the scale bar on the 
border between Chunks 1 and 2. Again, the second pass of Chunk 2 should still include the scale bar on at 

least one camera. 
 

 
 

When Chunk 2 is completed, the cameras are again stopped/paused, so that Diver 2 can leapfrog the 
scale bar and record a new depth measurement to prepare Chunk 3. 

 
 

http://www.coralrestoration.org/
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The photographing of chunks continues as explained until all chunks are photographed. Be sure to swim 
directly over scale bars TWICE- one time for each chunk that the scale bar borders- and that the depths of 

all scale bars used are recorded. 

Additional Tips           

• In ideal water conditions (>15 meters visibility, little to no current or surge), Diver 1 should attempt 
to swim ~2 meters above the reef at all times. This will allow for passes (yellow arrows in the 
diagrams above) that capture a 3-4 meter width of reefscape at a time, thus reducing the number 
of necessary passes and therefore, amount of swimming required. In shallower areas where this 
height above the reefscape cannot be maintained, note that the width of area captured by the 
images in a pass will decrease, and therefore, the distance between consecutive passes should 
also decrease. 

• At the outset of each chunk, photograph Diver 1’s hand holding up fingers that correspond to the 
chunk number. After each chunk is completed, turn off the cameras before photographing fingers 
for the following chunk. This will help with sorting the photos by chunk at the beginning of the 
stitching work. 

• Passes should be swum continuously within a chunk. In other words, do not stop the camera in the 
middle of the chunk. Diver 1 can continue shooting on time lapse mode as they turn and proceed 
back and forth across the reef chunk. 

• Diver 1 should hold the camera rig as far in front of their body as conditions (specifically, current 

and surge) allow. This will help remove the diver’s shadow from the captured images and result in 
clearer imagery and a clearer photomosaic. 

• Divers must communicate underwater to setup timing of moving of scale bars. If possible, plan for 

a set number of passes across each chunk before getting in the water. 

• When in doubt, make extra passes. Additional images will slow the stitching process, but will still 
result in a completed image. There is no solution for images that do not overlap or that do not 
include a portion of the chunk. 

• If desired, set the default mode of the GoPro cameras to time lapse mode at the correct interval. 

This will remove the chance of recording in a different mode when turning cameras on for the first 
time underwater. 

http://www.coralrestoration.org/
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• If the area to be mosaicked is shallow, be sure not to swim so fast that consecutive photos do not 
have sufficient overlap. Plan to swim more slowly in shallow areas (<2 meters depth) or set the 
GoPros to a faster time lapse interval (one picture per half second, for example) to help with 
picture-to-picture overlap. Decreasing the distance between cameras on the camera rig (i.e. 
moving the cameras closer together) may also help ensure overlap centrally between pairs of 
photographs. 

• Be aware that water conditions that are “too” ideal may actually inhibit photomosaic imagery 
acquisition. When the water is clear and still (no surge or wave action) and the sun is bright 
overhead, light ripples appear across the seafloor. These light ripples, due to their constant 
motion, will confuse the stitching software as it attempts to reconcile the ripples as “points” that 
seem to change drastically from picture to picture. Some software settings can account for these 
caustics in the source imagery, but will drastically increase the time needed to generate a 
completed photomosaic stitch. Thus, the true “ideal conditions” for a mosaic are light surface wave 
chop, minimal current, clear water, and/or overcast, early morning skies.  

http://www.coralrestoration.org/
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Part III – In-Water Procedures: Advanced/Hard Method 

Pre-Dive Equipment Setup 

Set up the GoPro cameras by checking for charged batteries, cleared microSD cards, and any scratches 
on the camera lenses. Place the cameras in the dive housings and attach the red dive filters. It is 
recommended that the camera’s default mode be set to Time Lapse at 1-second intervals to minimize 
the risk of accidentally shooting in video mode or being unable to alter mode settings once in the water. 
 
Attach the dive housings to the GoPro mounts at intervals of about one half meter. For very shallow areas 
where the diver will need to swim at or near the surface, mounting the cameras closer to each other will 
help ensure that there is sufficient overlap between the cameras, since the distance to target (reef) will be 
reduced. The cameras should typically be oriented to face straight down, though they may also be 

oriented at slight opposite angles (e.g. one camera ~5 forward and one camera ~5 backward) to aid 
in accurate stitching of very low rugosity or non-descript areas where more oblique views of the substrate 
can offer an increased number of points for alignment across photos. 
 
If necessary, assemble or prepare the scale bars. 
 
Finally, the specific area of reef to be surveyed should be identified before entering the water, if possible. 
CRFTM uses Google Earth to assess mosaic areas of appropriate size, which are then confirmed as suitable 
for restoration upon arrival and mosaicked. 

Image Capture and Diver Tasks 

This method of image acquisition should be utilized if the diver team is experienced in the photomosaic 
process. Water conditions can vary from sub-optimal to ideal, depending on the skill and experience 
level of the diver team. This method is also suitable for very large areas of reef (between 1,500 m2 and 
3,000 m2), dependent on the swimming abilities of the camera rig diver. In this method, Diver 1 is the 
diver with the camera rig and Diver 2 is the support diver. 
 
Once the photomosaic area has been identified, Diver 1 places the scale bars throughout the area, 
remembering the notes on scale bar placement from this document’s introductory section. For large, 
unfamiliar areas of reef, it may be helpful to place flagging tape, measuring tape transects, or subsurface 
floats around the perimeter or at the corners of the mosaic area. 
 
Once the scale bars and navigation aids have been placed, Diver 1 begins swimming the lawnmower 
pattern described in the Beginner/Easy Method above. The difference with this method is that Diver 1 now 
continues swimming back and forth across the full width or length of the photomosaic area until the entire 
area has been photographed, utilizing their scale bars and the natural features of the reef to guide their 
passes and overlap. 
 
This method eliminates “chunks” from the in-water acquisition and stitching processes, in favor of a more 
physically and mentally demanding swim by Diver 1. However, the result is a much more efficient method 
of in-water imagery acquisition and stitching. The total in-water swim is shorter because Diver 1 does not 
need to re-swim lines between chunks or wait for Diver 2 to maneuver the scale bars into place, image 
sorting post-dive is more straightforward since there are no chunks to organize, and the stitching speed 
improves dramatically because all photos are stitched as a single, massive “chunk” that does not need to 
be merged with its adjacent chunks. 
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Throughout this method, the most common role for Diver 2 is as a safety buddy diver for Diver 1, who can 
assist Diver 1 with any technical hiccups. However, this can change if the area to be mosaicked is quite 
large. The diver who is swimming the camera rig can easily become fatigued over the course of acquiring 
imagery for a large reef area and can consume their air much more quickly than their buddy.  
 
To balance the fatigue and air consumption factors across the diver team, proceed with site setup as 
described above. Diver 1 begins to swim the lawnmower pattern across the area and when they have 
reached a pre-determined point within the area or a pre-determined air pressure in their scuba tank, they 
can stop the cameras and switch roles with Diver 2, who takes the cameras, turns them back on, and 
continues photographing from Diver 1’s terminus. In this way, a well-coordinated team can photograph a 
large area of reef- neither diver becomes prohibitively fatigued and a situation where one diver is low on 
air and must surface while their dive buddy has air to continue the image acquisition work is avoided. 

Additional Tips           

• In ideal water conditions (>15 meters visibility, little to no current or surge), Diver 1 should attempt 

to swim ~2 meters above the reef at all times. This will allow for passes (yellow arrows in the 
diagrams above) that capture a 3-4 meter width of reefscape at a time, thus reducing the number 
of necessary passes and therefore, amount of swimming required. In shallower areas where this 
height above the reefscape cannot be maintained, note that the width of area captured by the 
images in a pass will decrease, and therefore, the distance between passes should also decrease. 

• Diver 1 should hold the camera rig as far in front of their body as conditions (specifically, current 

and surge) allow. This will remove the diver’s shadow from the captured images and result in 
clearer images and a clearer photomosaic. 

• When in doubt, make extra passes. Additional images will slow the stitching process, but will still 
result in a completed image. There is no solution for images that do not overlap or that do not 
include a portion of the chunk. 

• If desired, set the default mode of the GoPro cameras to time lapse mode at the correct interval. 
This will remove the chance of recording in a different mode when turning cameras on for the first 
time underwater. 

• If the area to be mosaicked is shallow, be sure not to swim so fast that consecutive photos do not 

have sufficient overlap. Plan to swim more slowly in shallow areas (<2 meters depth) or set the 
GoPros to a faster time lapse interval (one picture per half second, for example) to help with 
picture-to-picture overlap. 

• Be aware that water conditions that are “too” ideal may actually inhibit photomosaic imagery 

acquisition. When the water is clear and still (no surge or wave action) and the sun is bright 
overhead, light ripples appear across the seafloor. These light ripples, due to their constant 
motion, will confuse the stitching software as it attempts to reconcile the ripples as “points” that 
seem to change drastically from picture to picture. Some software settings can account for these 
caustics in the source imagery, but will drastically increase the time needed to generate a 
completed photomosaic stitch. Thus, the true “ideal conditions” for a mosaic are light surface wave 
chop, minimal current, clear water, and/or overcast, early morning skies. 
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Part IV – Additional In-Water Procedures 
The following sections detail additional in-water procedures that may help with image acquisition for large 
reef areas (simultaneous diver teams, diver propulsion vehicles), areas where higher resolution 
photomosaics are needed (DSLR cameras), or small-scale areas depicting non-Acroporid coral restoration 
(massive/mounding corals). CRFTM has used each of these techniques to varying extents but their uses in 
day-to-day operations are too uncommon to warrant independent sections. Additionally, other 
organizations have developed more sophisticated procedures for utilizing DSLR cameras and 3-D 
modeling and should be consulted in conjunction with this document. 

Simultaneous Diver Teams 

A potentially useful amendment to the Advanced/Hard in-water image acquisition method described in 
the previous section is the use of two simultaneous diver teams. By utilizing two pairs of divers- each 
with their own set of scale bars, cameras, and camera rigs- massive areas of reef can be covered twice 
as quickly. With this technique diver teams ideally begin swimming their passes at opposite sides of a 
mosaic area and work towards each other until they meet in the middle. The photos from both teams 
are then combined during the stitching process to create the single, large photomosaic.  
 
The most difficult aspect of this technique is confirming that the central region of the mosaic where the dive 
teams meet contains sufficient overlap between the teams, to ensure that all portions of the area have 
been imaged in the water. Coordination between the pair of “Diver 2”s may be necessary here. 

Diver Propulsion Vehicles (Scooters) 

Diver Propulsion Vehicles (DPVs), or “scooters”, also have the potential to make in-water imaging of larger 
reef areas more efficient. The largest hurdle to achieving results with this technique is simply finding the 
correct DPV model. Many models now come with GoPro attachment mounts but they are typically forward-
facing and only offer space for a single camera. Thus, CRFTM has created a PVC bar system strapped to 
the underside of a Yamaha 220Li Seascooter with zip-ties, as shown below. 
 
While DPVs can accelerate the process of in-water image acquisition for large areas, it is important to 
choose a model with appropriate speed settings. DPVs that move too quickly can create motion blur on 
photos or contribute a lack of front-to-back overlap between consecutive images. The recommended 
GoPro Time Lapse setting for most DPVs is therefore ½ second and DPVs should typically be run on their 
slowest speed setting.  
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DSLR and Mirrorless Cameras          

If the final photomosaic resolution offered by the GoPro camera setup described above is not sufficient, 
either for monitoring or aesthetic purposes, DSLR or high-resolution mirrorless cameras can be used. These 
systems will offer much higher resolution of both in-water images and final photomosaics but that resolution 
will come with several associated costs. 
 
First and foremost, DSLR/mirrorless cameras are significantly more expensive than GoPros and may 
become prohibitively expensive when the costs associated with waterproof housings are factored into the 
equation. It should also be noted that these physically larger camera systems are much more difficult to 
handle underwater and can make the swimming of areas >1,000 m2 incredibly physically demanding.  
 
CRFTM has occasionally used a single DSLR camera and underwater housing to generate high resolution 
photomosaics for print and media/communications purposes. For these mosaics, a small (25-50 m2) area of 
restored reef is photographed with the aforementioned lawnmower pattern with the single DSLR camera 
and 35mm lens facing straight down. In this scenario, the camera’s built-in intervalometer is used to auto-
focus and capture images at one second intervals. However, not all DSLR/mirrorless cameras come with 
built in intervalometers and after-market firmware upgrades may be necessary. 
 
Multiple DSLR/mirrorless cameras may be used if an appropriate camera housing rig can be crafted. Be 
advised that while increasing the number of high-resolution images will create a more accurate and higher 
resolution photomosaic, the stitching process will require more time and/or computer power. 
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Massive/Mounding Corals – 3-D Acquisition 

CRFTM has recently begun restoring mounding corals within the genus Orbicella by outplanting individual, 
half-dollar-sized plugs in groups of 10 to 70. Typically, these groupings are placed on existing Orbicella 
skeletons, which range in size from 25 centimeters to 2 meters in diameter. To gain a more accurate picture 
of these rounded structures, these skeletons are photographed before and after outplanting, with the 
intention of recreating a 3-dimensional skeleton and the outplanted plugs.  
 
To accomplish this, a GoPro or Olympus Tough point-and-shoot camera is used to capture 10-15 images 
from directly above the skeleton (in the same was the lawnmower pattern captures the top-down imagery 
for the other photomosaic techniques) and 40-60 images are taken from vantage points surrounding and 
slightly above the skeleton, to ensure the sides of the skeleton are properly depicted by the software. To 
generate the 3-D model in the stitching software, the side-view images should minimize the amount of 
water shown in the background, hence the camera’s orientation slightly above the skeleton. 
 
Because of the relatively small size of these model areas, smaller scale bars, in the form of flattened 
circular disks or small aluminum bars are recommended. For the most accurate scaling measurements, 
several of these smaller markers should be placed on/around the skeleton substrate for models created 
both before and after outplanting. 
 
Additional information on acquiring imagery of 3-D Orbicella spp. restoration and making relevant 
measurements in Agisoft Metashape can be found in the 3-dimensional monitoring manual, available at 
www.coralrestoration.org/white-papers. 
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Part V – Stitching and Computer Processing 

Overall Procedures 

Stitching photographs into photomosaics requires two main steps. First, a photomosaic of each chunk 
must be built from that chunk’s individual photos. Second, the chunk photomosaics must be aligned and 
merged to create the final photomosaic for the site. The first step is always accomplished with Agisoft 
Metashape while the second step can be accomplished in Metashape (recommended) or in Adobe 
Photoshop. (Note: if in-water image acquisition followed the Advanced/Hard method in Part II above, 
you will only have one chunk and therefore only need to complete the stitch for that chunk in 
Metashape). 

Sorting Photos 

Photos should be sorted immediately after the in-water work is completed to minimize the loss of 
memory or information from the day’s work. Be aware that moving the location of photos after stitching 
has begun will break the project links in Metashape and will disrupt stitching. For this reason, it is 
recommended that a consistent, repeatable file naming and organization structure be created before 
mosaicking occurs and is followed over the life of photomosaic program or project. 

Introduction to Agisoft Metashape 

Agisoft Metashape is a powerful 3-D modeling software with the capacity to align and merge 
large numbers of photographs into a single mosaic or 3-D model. Upon opening Metashape for 
the first time, you will see a white Workspace on the left and grey model area in the center 
(note that all screenshots in this manual come from MacOS). 
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Immediately above the Workspace is a small menu bar with icons for adding chunks, photos, markers, and 
scale bars. Above those is another menu bar with options to open and save files, as well as change the 
appearance of the model displayed in the central gray area. 
 

 
 
The standard order of operations for this manual’s methodology is as follows: 

1. Import Photos (into separate chunks) 
2. Align Photos (for each chunk) 
3. Detect/Assign Markers 
4. Orthorectify and Scale 

 
For alignment and merging of chunks in Agisoft Metashape, the steps continue as such: 
      6.   Align Chunks 
      7.   Merge Chunks 
 
Once chunks have been aligned (or if the project only contained a single chunk and no chunk alignment is 
necessary): 
      8.   Build Models 
      9.   Build Orthomosaic 
    10.   Export Orthomosaic 

Importing Photos and Photo Alignment 

Open Agisoft Metashape and create new chunks as needed. Photos do not need to be sorted by camera 
in Metashape, so simply import all photos from a specific chunk into that Metashape chunk workspace. This 
can be accomplished either by clicking the icons immediately above the Workspace area or by selecting 
the “Import Photos” option under the “Workflow” menu. Be aware that a chunk must be selected in order to 
import photos and that selecting a different chunk requires double-clicking that chunk. 
 
Note: If using a GoPro Hero camera or another camera with a rolling shutter, users should follow Tools -> 
Camera Calibration and select “Rolling Shutter Compensation -> Full (Txyz, Rxyz)” for all cameras used in 
the Chunk. 
 
Once all photos are imported to their chunk workspaces, photos can be aligned. Follow Workflow -> Align 
Photos to align the photos in the selected chunk, or use Batch Processing, described below. In most cases, 
“High” accuracy is sufficient, along with default selections for the other settings. Click OK. However, for 
images with significant caustics (i.e. sunlight ripples, diver shadows in every photograph), users should 
switch the “Generic Preselection” setting from “On” to “Off”. Note that this change will significantly 
increase the amount of time needed to align the photos but will allow Metashape to successfully stitch 
areas with caustics. At the completion of this step, each chunk should have a Sparse Point Cloud 3-D model 
in the project window. 
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Scaling and Orthorectifying the Model 

If Agisoft’s coded targets have been used during the in-water image acquisition process, begin the 
orthorectification and scaling steps by following Workflow -> Detect Markers. Once this is complete, 
create scale bars by selecting two targets, right clicking, and choosing “Create Scale Bar”. 
 

 
 
In the Scale Bars Panel in the lower left side of the screen, input the known distance between the center 
points of the coded targets (in meters) and the error of that measurement (usually 0.001m or 0.0005m 
depending on ruler used). Once all scale bars have been created and assigned their appropriate length, 
click the blue circular “Refresh” button at the top of this panel. Your model should re-size itself and a “[S]” 
will appear next to the chunk in the upper left corner panel. Your model is now scaled. Pressing “0” will 
automatically fit the model to the screen again. 
 

 
 

After repeating the scaling process for each chunk, orthorectification can occur. Orthorectification is the 
process by which objects of varying distances from the camera can be “normalized” to the same 2-
dimensional plane. In other words, objects at deeper depths are brought closer to the camera and objects 
at shallower depths are moved further away from the camera. Orthorectification is a critical step in the 
process as it allows for consistent measurements of objects throughout the image, regardless of those 
objects’ depths or distances from the camera. 
 
For each target or scale bar with a known depth, select one of the two targets and assign a depth 
measurement (in meters) for that target in the “Z” column of the target panel. Be sure to put a negative 
sign “-“ before the depth measurement (e.g. “-4.0” for a target located at a depth of 4 meters). Repeat 
for at least three targets or scale bars found in a non-linear orientation throughout the mosaic model area, 
ignoring the X- and Y-coordinate (latitude and longitude) columns. 
 
Next, assign an error value to each of these targets’ depth measurements like so: “1000/0.1” for a dive 
computer or depth device set to metric units OR “1000/0.3048” for a dive computer or depth device set 
to imperial units. In Metashape’s error column, the value before the “/” corresponds to the error of the X- 
and Y-coordinates, while a value after the “/” applies to the Z-coordinate. Since this technique does not 
utilize latitude and longitude values for the X- and Y-coordinates, assigning an arbitrarily high error value 
here (1000) relative to the error of the depth z-coordinate forces Metashape to accurately orient the 
model based on the z-plane only, without influence from the x- and y-planes, which exist in untethered 
space. The two z-coordinate error values (0.1m and 0.3048m) are simply taken from the common accuracy 
thresholds from metric and imperial (+/- 1ft is equal to +/- 0.3048m) dive computers. Click the blue 
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circular Refresh button again, and now a “[R]” should be displayed next to the chunk. The model is now 
orthorectified. 
 

 
NOTE: In the above example, depths were taken in feet and then converted to meters for use in Agisoft (e.g. 23 feet = 7.0104 

meters). 

 
 

Manually Placing Points in Metashape 

Occasionally, Metashape will fail to recognize a coded target (due to lack of clear imagery of the target 
or due to the size of the target relative to the size of the area). In these instances, it is necessary to 
manually place markers on the targets. To do this, locate a target in the model’s sparse point cloud. 
Once a target has been located, right click on this portion of the model and select “Filter Photos by 
Point”. 
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The selection of source images in the bottom panel of Metashape will filter to only show photos with the 
point that was clicked on in the model. Double click on a photo that shows the target clearly to bring the 
photo up in the main Metashape window. Then, right click on the center of the target and choose “Add 
Marker”. 
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A new marker will be created, which can then be re-named in the lefthand panel. The marker will also 
appear in the other filtered photographs that show the target. Select 3-4 other photos and click-and-drag 
the newly created marker until it is accurately centered on the target in each. Note that markers that have 
been placed by the user will be green, while markers that have only been placed by Metashape’s location 
estimator will remain blue until moved by the user. 
 
Repeat these steps for any targets or scale bars that Metashape could not initially identify and then 
proceed to the scaling and orthorectification steps. 

Aligning and Merging Chunks in Metashape 

Once a series of chunks have each scaled and orthorectified, they can be aligned with adjacent chunks 
and then merged to create a larger photomosaic. This step has the potential to be the most time-consuming 
of the photomosaic process. Thus, any reduction in the number of photos or chunks that are used in the 
project is desirable. 
 
Chunks should be merged two at a time and in a “cascading” fashion. For a series of chunks 1-8, with the 
reef section shown in Chunk 1 adjacent to the reef section shown in Chunk 2 and so on, the chunks should be 
aligned and merged like so: 
 

1. Align Chunks 1 and 2; Merge Chunks 1 and 2 
2. Align Chunks 3 and 4; Merge Chunks 3 and 4 
3. Align Chunks 5 and 6; Merge Chunks 5 and 6  
4. Align Chunks 7 and 8; Merge Chunks 7 and 8 
5. Align Chunk 1&2 with Chunk 3&4; Merge Chunk 1&2 with Chunk 3&4 
6. Align Chunk 5&6 with Chunk 7&8; Merge Chunk 5&6 with Chunk 7&8 
7. Align Chunk 1&2&3&4 with Chunk 5&6&7&8; Merge Chunk 1&2&3&4 with Chunk 5&6&7&8 
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In the example images below, the photos of the two adjacent chunks have each been separately aligned 
and the resulting point clouds have been scaled. There is clear overlap between the two chunks around the 
scale bar labeled “Target 12”. 
 

 
 

 
 
From here, the goal is to manually place 3-4 points in the exact same location on each chunk. In the images 
below, Points 1-3 have been added to the same parts of both chunks, using well-defined benthic features 
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(a coral colony, a rock, etc.) to accurately place the points. Ensure that the points are labeled exactly the 
same between the overlapping chunks. 
 

 
 

 
 
Follow Workflow -> Align Chunks and choose “Target Based” from the drop-down menu. Provided you 
have scaled your point clouds before this step, the chunks should align such that switching views between 
the two chunks displays the point clouds in relative orientation to each other. At this point, follow Workflow 
-> Merge Chunks and choose “Merge Markers” (and any other desired products that have been built to 
this point). 
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A new, merged chunk will be created. From here, this chunk can be scaled and orthorectified, and 
additional products such as models, orthomosaics, and DEMs can be built. Alternatively, this new merged 
chunk can also be used in additional Align/Merge steps if the project has additional chunks to be merged. 
 

 
 
Once all chunks have been aligned and merged into a single, final chunk, a model can be built and used to 
create an exportable photomosaic. 
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Building Models, Building Orthomosaics, and Exporting Orthomosaics 

To build the model (referred to as a “Mesh” in previous versions of Metashape) needed for creation of a 
photomosaic, follow Workflow -> Build Model (or Batch Process, as described below) and check that 
Source Data is set to “Depth Maps” and the face count is 200,000. Accept the default options for the 
remainder of the settings. Click OK. 
Once this is completed, follow Workflow -> Build Photomosaic. Select Planar Type, Model Surface, and 
Mosaic Blending mode. Click OK. 
 

 
 

To export a photomosaic, select the desired chunk. Right click and choose Export -> Export Orthomosaic -> 
Export JPEG/TIFF/PNG. Choose the file type, location, and any scaling desired (i.e. pixel dimensions set to 
1mm x 1mm) for the photomosaic and click OK. 

Aligning and Merging Chunks in Photoshop 

With sufficient overlap between chunks, the final chunk photomosaics can be aligned and merged easily 
with Adobe Photoshop CC. For quickest results, this manual recommends exporting individual chunk 
photomosaics as JPEG files. 
 

1. Open each chunk photomosaic as a “tab” in Photoshop CC. 

2. Follow the path File→ Automate→Photomerge 
3. Ensure “Layout” is set to “Auto” and click “Add Open Files” 
4. Select each chunk photomosaic from the center list and then click “Ok” 
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With sufficient overlap between the Chunk files, this will generate a full site photomosaic that can be 
exported from the “File” menu and saved as a JPEG, TIFF, or Photoshop file format. However, this 
technique is not recommended, as it will not produce a truly ortho-rectified, scaled final photomosaic 
image and additional Metashape products such as 3-D models, DEMs, and Stitch Reports will be 
incomplete. 

Batch Processing in Agisoft Metashape 

Batch processing can automate the stitching process and save considerable time. However, batch 
processing should still be monitored to ensure that each step runs correctly and that the final products are 
complete and accurate. 
 
Follow Workflow -> Batch Process. Click Add and define the job and parameters. Jobs can be added, 
edited, removed, and reorganized with the appropriate buttons. Taking advantage of the option to save 
the Metashape project file (.psx) after the completion of each job is highly recommended. 

Exporting Large Files 

Depending on the computer used and size of the orthomosaic being exported from either Metashape, 
exporting to a JPEG file format may fail. In this case, use the PNG image file format or, if a JPEG image 
is necessary, down sample the exported file through the Export Photomosaic dialog box by setting the 
pixel dimensions to larger values (e.g. 0.002m x 0.002m instead of a default value such as 0.00058m x 
0.00058m). 
 
 

 
 

Optional Steps – DEMs and Textured Models 

Once models have been built for a scaled and orthorectified chunk, users may choose to build digital 
elevation models (DEMs) and model textures. To build a DEM, go to Workflow -> Build DEM and use the 
settings shown below. Then, the DEM may be viewed and exported from the list of options beneath the 
Chunk. 
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Building a texture of the model can be very useful for models/mosaics of individual coral colonies 
(particularly massives) and may also be done for large-scale mosaics, though the computer power and 
time needed may be prohibitive. Follow Workflow -> Build Texture and choose the settings shown below. 
The textured version of the model can then be seen in the model by choosing “Model Textured” from the 
Model icon’s drop-down menu. 
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Tips for Orthorectification and Scaling 

This manual recommends avoiding the use of the same target multiple times in a mosaic. Using unique 
targets for each scale bar and/or depth measurement will avoid confusion (both on the part of the user 
and on the part of Metashape) about which targets constitute which scale bars and at what depth or 
location they exist in a mosaic. The creation of accurate scale bars may fail if multiple instances of a 
target exist in a mosaic area, as Metashape will not know which instance of a target to use in creating a 
specific scale bar and assigning the known scale. 
 
During the orthorectification of a model, Metashape will occasionally invert the orientation, so that the 
top-down view becomes defined as the “bottom-up” view. Thus, building an orthomosaic from this 
projection will result in an inverted image. To fix this, one or more defined targets with an assigned 
depth value (Z-coordinate) must be manually placed on the model and then given the known depth 
value. To do this, follow XXX to reset the default orientation of the model. Then, follow the steps 
described above for manual creation and placement of targets throughout the model. Note that these 
new targets will have arbitrary X- and Y-coordinate values assigned to them upon their creation. Assign 
the Z-coordinate values and errors as normal. Click the circular “refresh” icon above the targets panel 
and repeat this process until the model is properly orthorectified with the correct top-down view. 
 
The quickest and easiest way to determine in a model or sparse point cloud is inverted is to turn on the 
camera locations by clicking the camera icon in the toolbar at the top of the main panel. If the model is 
inverted, the points of the point cloud will appear in front of the blue camera location markers (top 
photo, below). If the model is correctly oriented, the point cloud will appear behind the camera location 
markers (bottom photo, below). 
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Part VI – Final Photomosaic Analysis 

 

 
 

 
 
 

Goals 

For CRF’s purposes, basic ecological data is extracted from photomosaic stitches of a reef site. Images 
are layered in Adobe Photoshop CC by outlining all individual coral colonies and filling in each outlined 
area. These layered .psb files are then exported from Photoshop and analyzed in FIJI (formerly ImageJ) 
to extract a variety of metrics such as coral counts, size frequencies, and area cover. NOTE: the following 
steps reflect CRF’s outplanting techniques and monitoring requirements; other methods or analyses 
may require additional or revised steps. 

Photoshop Setup 

1. Open the exported orthomosaic .jpg file in Adobe Photoshop CC. Right click the .jpg > open with 
> Adobe Photoshop CC. 
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2. Create a background fill layer. Go to Layer > New Fill Layer > Solid Color. Name it 
“Background.” Click OK. Set the background to BLACK or #000000. Click OK. 
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a. Create new layers. In the lower right-hand corner of the Layers Panel, click the “Create a new 
layer” icon. (If the Layers Panel is absent, go to Windows > Layers.) A new layer, Layer 1, 
should appear in the Layers Panel. Create the following layers : 

a. “Timepoint CoralSpecies” This layer is for highlighting all the corals of a single coral 
species. Create an individual layer for each species of coral in the mosaic so that the 
species can be analyzed independently. Name the layer based on the monitoring 
timepoint (1M, 6M, 1Y, etc.) and the coral species being monitored (Staghorn, Elkhorn, 
etc.)  

b. “Scale bars” This layer is for tracing and highlighting the scale bars. 
c. “Clusters” This layer is for marking each outplanted “cluster” along the transect or 

within the mosaic area. 
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3. Unlock the orthomosaic layer. Click the lock. It will now become “Layer 0”; rename it based on the 
name of the area being monitored. 
 

 
 

4. Rearrange the layers so that the Background layer is at the bottom. Click a layer and drag it to 
reorder the layers into the following order: 

 

 
 

5. Zoom in (lower left corner) to get a better working view of the individual coral colonies in the 
photomosaic for labeling the clusters. 
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6. Select the Clusters Layer in the Layers Panel. 
 

7. Select the Brush Tool (B) from the Tools Panel. In the Brush panel (located at the top), make sure the 
opacity and flow are set 100%. Also make sure the brush is a decent size (~150 – 300 pixels, 
depending on the resolution of your photomosaic) and the hardness is set to the maximum. (Size 
and hardness are found in the first dropdown option in the Brush panel, boxed below). 

 

 
 

 
8. Set the color using the Color Picker (located at the bottom of the left-hand Tools Panel) to BLUE or 

#0000ff. 
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9. Paint one dot at the center of each cluster of corals. This will allow you to quickly locate and find 
the corals within the mosaic as you proceed through the tracing and highlighting steps below.  

 

 
 

10. Select the Horizontal Type Tool in the left-hand Tools Panel. This tool is used to add text and will 
be used to mark the cowtag numbers for each cluster. Make sure to swap colors to white, using the 
Color Swatches (located at the bottom of the left-hand Tools Panel) so that the text can be seen 
over the blue dots.  
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11. Add text. Click anywhere on the image to add a new text object and type in the correct cowtag 
number, genotypic information, or other identifier for a cluster of corals. Note: The text object will 
be added as a new Layer above the selected Layer in the Layer Panel, so be sure to have the 
Clusters Layer selected. 

12. Select the Move Tool (V) in the left-hand Tools Panel. Hovering over a text object, click and drag 
to move. Place the text object to mark the correct cluster.  

 

 
 

13. Hide/Unhide Clusters Layer as needed. In the Layers Panel, click the eye icon next to a Layer to 
make that layer invisible/visible again. This will help view the cluster tags, genetic tags, or other 
identifying markers. 
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14. Repeat until every cluster has been labeled appropriately. Note that tags with text or colors do 
not always render properly due to poor in-water conditions or stitching abberations. It is helpful to 
have in-water maps or notes to corroborate any coral identification information in the mosaic. 

 

 
 

15. Group the label layers. In the Layers Panel, select all of the text layers and the Clusters Layer; 
click the topmost text layer and, while holding Shift, click the Clusters Layer (should be the bottom-
most layer in the selection). Click the “Create a new group” icon and rename this group 
Cowtags/Genetic Markers/etc.. This will organize and declutter the Layers Panel, making it easier 
to work throughout the following steps.  
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Outlining and Shading 

1. Select the Polygonal Lasso Tool (L) in the left-hand Tools Panel. Lasso Tools will be used throughout 
segmentation (tracing). Right click the icon to see the different options: 

a. Polygonal Lasso Tool: This tool is used to outline and select polygons (i.e. - the scale bars). 
b. Lasso Tool: This tool is used to outline and select freeform shapes (i.e. - the coral colonies). 

 

 
 

2. Outline the scale bars. The Polygonal Lasso Tool works by clicking to create corners while outlining 
an object. When finished outlining the object, double click to finish off the selection. A flashing 
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border will appear, surrounding your selection. There are two settings in the Lasso panel (located 
at the top) that are of note: 

a. Add to selection: Use this tool to start a selection and continue adding to it. 
 

 
 

b. Subtract from selection: Use this tool to remove areas from the current selection.  
 

 
 

3. Select the Scale bars layer in the Layers Panel. 
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4. Select the Brush Tool from the Tools Panel. In the Brush panel (located at the top), make sure the 
opacity and flow are set 100%. Also make sure the brush is large and the hardness is maximized. 

 
5. Set the color using the Color Picker (located at the bottom of the left-hand Tools Panel) to RED or 

#ff0000. 
 

6. Paint over the entire scale bar selection. The selection ensures that only parts of the image bound 
by the flashing selection border are painted. Remember to paint all selected objects for the layer 
(i.e. all scale bars in the photomosaic).  
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7. Deselect the selection. Go to Select > Deselect. 
 

8. Select the coral layer. 
 

9. Select the Lasso Tool. Right click the Polygonal Lasso Tool in the left-hand Tools Panel to change 
Lasso Tools.   

 

 
 

10. Select the “add to selection” option for the Lasso Tool. 
 

11. Outline a live coral colony using the Lasso Tool. Recall the two settings in the Lasso panel (located 
at the top) that are of note – add to selection and subtract from selection – and use when 
appropriate. For this step, the use of a drawing tablet such as the Wacom Intuos Pro may be 
beneficial. 

 
12. Repeat until every coral from a single species within the photomosaic is selected. 

 
13. Save the Selection periodically to allow for re-selection (correction) and in case of a computer 

crash.  
a. Saving a new selection. Go to Select > Save Selection… and name the selection based on 

the species selected (below left). Do this the first time the selection is saved. 
b. Saving over a selection. Go to Select > Save Selection… When the Save Selection pop-

up box appears, select the name of the previous selection from the Channel drop-down 
menu (below middle). Do this as more corals are added to the files selection and are 
saved. 

c. Loading a selection. Go to Select > Load Selection… When the Load Selection pop-up 
box appears, select the name of the previous selection from the Channel drop-down menu 
(below right). Do this when returning to the coral tracing and selection process after 
deselecting the selection or after closing out of Photoshop. 
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14. After selecting all corals of a species in the photomosaic, click the coral Layer in the Layers Panel 
for the species of coral selected.  

 

 

http://www.coralrestoration.org/


 
 
 
 
 

 

Coral Restoration FoundationTM • 89111 Overseas Highway, Tavernier, Florida 33070, USA • (305) 453 7030 

www.coralrestoration.org 

48 
 

CORAL RESTORATION FOUNDATIONTM WHITE PAPER 
Coral Restoration FoundationTM Photomosaic Manual: Third Edition – October 2023 

 

 
15. Select the Brush Tool from the Tools Panel. In the Brush panel (located at the top of the window), 

make sure the opacity and flow are set 100%. Also make sure the brush is large and the hardness 
is maximized. 

 
16. Set the color using the Color Picker (located at the bottom of the left-hand Tools Panel) to WHITE 

or #ffffff. 
 

17. Paint over the entire selection. Some tips: 
a. Paint as you go – Paint after every few clusters or after every cluster to ensure that you 

do not skip any corals. 
b. Make the brush size as big as possible – This will help cover more pixels with less effort.  
c. Go over everything a few times – This will ensure that no pixels representing live corals 

get left out of the highlighting. 
 

 
 

18. Save your final product! Go to File > Save As.  
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Exporting the Image 

1. Hide the Cowtags Group and the orthomosaic/reef imagery Layer by clicking the eye icons in the 
Layers Panel. 

 
2. Export the file. Go to File > Export > Export As… Export the file as a JPG. Some things to check 

before clicking Export All: 
a. Make sure the Quality is at 100%.   
b. Make sure the “Convert to sRGB” box is checked. 
c. Make sure the file size is not too large. It shouldn’t be above 5 MB.  
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3. Click Export All… and save the image to the desired location. 
 

4. Now, hide the scale bars Layer by clicking the eye icon in the Layers Panel. 
 

5. Export the file as before. 
 
 

FIJI Setup 

1. Open FIJI (previously, ImageJ). The FIJI Toolbar will appear. 
 

 
 

2. Open both exported images in FIJI. Go to File > Open. Navigate to the .jpg images you exported 
from Photoshop. Alternatively, navigate to the .jpg images in a Finder window and then click and 
drag the images to the FIJI window. A new window should pop up for each image. 
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3. Select the FIJI window with the .jpg that has the scale bars. 
4. Zoom in to the scale bar. Hover over the scale bar with the mouse cursor and press the “+” key to 

zoom in, readjusting after each keystroke.  
 

 
 

5. Select the Straight tool from the FIJI Toolbar.  
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6. Measure the length of the scale bar. Click on one end of the scale bar and drag the yellow line to 
the other end. Keep it parallel with the length of the scale bar. 

 

 
 

7. Set the scale. Go to Analyze > Set Scale… The “Distance in pixels” field should be filled out 
automatically from the last step. Enter the “known distance” and “unit of length” fields based on 
the scale bar. (The scale bar shown here is 50 cm.) NOTE: Make sure the “Global” box is checked. 
This should set the scale for any image you have opened in FIJI. Alternatively, you could set the 
same scale after selecting the other FIJI window, the exported image with only corals. 
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8. Select the other FIJI window, the .jpg with only corals. 
 

9. Convert the Image to 8-bit. Go to Image > Type > 8-bit. (It should already be selected.) 
 

10. Adjust the Threshold. Go to Image > Adjust > Threshold. A dialogue box will appear to allow for 
customization. Set the values to run from 5 to 255. Notice the image will automatically change to 
B&W. This step allows FIJI to just analyze the black portions of the image, which are the corals, 
and exclude the background.  

 

 
 

11.  Set Measurements. Go to Analyze > Set Measurements… A dialogue box will appear to allow 
for customization. Select the boxes next to Area, Feret’s diameter, and Add to overlay. (Feret’s 
diameter is defined in FIJI as the longest distance between any two points along the selection 
boundary, a.k.a. maximum caliper length.) Click OK. 
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Analyzing the Data 

1. To analyze particles, go to Analyze > Analyze Particles… A dialogue box will appear to allow 
for customization. Select the boxes next to Display results, Clear results, and Summarize. Also 
select Outlines from the Show drop-down menu, then click OK. 

 

 
 
Multiple windows should appear. Two are data tables – a Summary table and a Results table with data 
from each “particle” (or coral). The last one is a drawing of the file with every “particle” outlined and 
numbered to correspond with the Results table. 
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It is important to notice how the particles are numbered on the Drawing. They are numbered in increasing 
order from top to bottom, left to right. Corals in a cluster will almost never be ordered consecutively. These 
numbers will also be altered if corals die before the next timepoint or if the next mosaic of the area has a 
different orientation, making colony-to-colony comparisons through time very difficult.  
 

 
 
NOTE: At times, the .jpg will come with a white border surrounding the entire image or even some random 
white pixels that get measured as “particles”. Take care to review the results FIJI gives you, so as not to 
include non-coral points and skew the results. Adjusting the threshold sliders in Step 10 above may also 
help avoid this problem. 
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If you notice any extremely large or small values, consult the Drawing and the original .psb file to verify if 
they are corals or not. If not, close out of the Results, Summary, and Drawing windows and redo the 
Analysis adjusting the “Size (cm2):” value in the Analyze Particle window to exclude any particles that are 
above or below a certain size. 
 

2. Copy the data into an Excel file for analysis. Some things to note: 
a. FeretX/FeretY. These are the (x,y) coordinates of the start of the Feret measurement. 
b. FeretAngle. This is the angle from the (x,y) coordinates that the Feret measurement runs. 
c. MinFeret. The minimum caliper distance of the particle. 

 
3. Save the Drawing. Go to File > Save As > jpeg. This will allow you to cross-reference your results 

with the Drawing to determine which corals were which sizes, useful for comparisons across 
timepoints.  
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Additional resources can be found on the Coral Restoration FoundationTM website: 
www.coralrestoration.org 

 
 
 
 
The following persons have helped inform the CRFTM Photomosaic process throughout the years. For more 

information on different in-water image acquisition techniques, Agisoft processing advice, additional 
software such as TagLab or Viscore, and other general workflows, consider contacting them: 

 
Art Gleason, University of Miami 

Nicole Pederson, Scripps Institution of Oceanography 
Clinton Edwards, Scripps Institution of Oceanography 

Will Greene, Perry Institute of Marine Science 
 

 
 
 
 
 
 
 

 
 
 

  

http://www.coralrestoration.org/
http://www.coralrestoration.org/


 
 
 
 
 

 

Coral Restoration FoundationTM • 89111 Overseas Highway, Tavernier, Florida 33070, USA • (305) 453 7030 

www.coralrestoration.org 

58 
 

CORAL RESTORATION FOUNDATIONTM WHITE PAPER 
Coral Restoration FoundationTM Photomosaic Manual: Third Edition – October 2023 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

© 2023 Coral Restoration FoundationTM 
All rights reserved. 

http://www.coralrestoration.org/

	AUTHORS:
	Alexander M. Neufeld, Garrett Fundakowski
	AUTHORS:
	Alexander M. Neufeld, Garrett Fundakowski
	Coral Restoration FoundationTM, Tavernier, FL 33070
	AUTHORS:
	Alexander M. Neufeld, Garrett Fundakowski
	Coral Restoration FoundationTM, Tavernier, FL 33070
	CORAL RESTORATION FOUNDATIONTM
	Coral Restoration FoundationTM Photomosaic Manual
	Alexander M. Neufeld
	Garrett Fundakowski
	Coral Restoration FoundationTM, Tavernier, FL 33070
	Suggested citation: Neufeld, A., Fundakowski G. (2023). Coral Restoration FoundationTM Photomosaic Manual: March 2023 Edition [White paper]. Retrieved [date], from Coral Restoration FoundationTM
	Table of Contents
	Purpose
	The purpose of this document is to (a) provide divers with the basic knowledge and skillset for creating 2-dimensional, underwater photomosaics- also referred to as orthomosaics, structure from motion (SfM), or several similar descriptors- and (b) exp...
	Background

	Part I – Introduction to In-Water Image Acquisition
	Theory
	CRF’s Required Equipment
	Choosing Your Equipment (Cameras and Scale Bars)

	Part II – In-Water Procedures: Beginner/Easy Method
	Pre-Dive Equipment Setup
	Image Capture and Diver Tasks
	Additional Tips

	Part III – In-Water Procedures: Advanced/Hard Method
	Pre-Dive Equipment Setup
	Image Capture and Diver Tasks
	Additional Tips

	Part IV – Additional In-Water Procedures
	The following sections detail additional in-water procedures that may help with image acquisition for large reef areas (simultaneous diver teams, diver propulsion vehicles), areas where higher resolution photomosaics are needed (DSLR cameras), or smal...
	Simultaneous Diver Teams
	Diver Propulsion Vehicles (Scooters)
	DSLR and Mirrorless Cameras
	Massive/Mounding Corals – 3-D Acquisition

	Part V – Stitching and Computer Processing
	Overall Procedures
	Sorting Photos
	Introduction to Agisoft Metashape
	Importing Photos and Photo Alignment
	Scaling and Orthorectifying the Model
	Manually Placing Points in Metashape
	Aligning and Merging Chunks in Metashape
	Building Models, Building Orthomosaics, and Exporting Orthomosaics
	Aligning and Merging Chunks in Photoshop
	Batch Processing in Agisoft Metashape
	Exporting Large Files
	Optional Steps – DEMs and Textured Models
	Tips for Orthorectification and Scaling

	Part VI – Final Photomosaic Analysis
	Goals
	Photoshop Setup
	Outlining and Shading
	Exporting the Image
	FIJI Setup
	Analyzing the Data


